summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGalen Guyer <galen@galenguyer.com>2022-12-12 15:32:50 -0500
committerGalen Guyer <galen@galenguyer.com>2022-12-12 15:32:50 -0500
commit3c6c5ab9277de4d8444212223e741af5e0dbbc46 (patch)
tree2b1e759414f717fbb18ba10415ecec350667d79e /Cargo.toml
WS audio shit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..fcf469d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "opentrunk"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+axum = { version = "0.6.1", features = ["ws"] }
+base64 = "0.13.1"
+bytes = "1.3.0"
+crossbeam-channel = "0.5.6"
+csv = "1.1.6"
+env_logger = "0.10.0"
+include_dir = "0.7.3"
+log = "0.4.17"
+mime_guess = "2.0.4"
+ogg-opus = "0.1.2"
+serde = { version = "1.0.148", features = ["derive"] }
+serde_json = "1.0.89"
+tokio = { version = "1.22.0", features = ["macros", "rt-multi-thread"] }